8" Touchscreen non-responsive (Android Auto Glitch)

EvlNvrDys

Rank VI

Champion I

Sep 1, 2021
509
901
2,964
Milford, NJ 08848
First Name
Greg
Last Name
Bradley
Member #

105178

So it happens maybe once every 3 weeks, and it's basically nothing more than annoying when it does. It's as simple as turn truck off, open door (to finish process of turning off), restart Bronco, everything works again.

Sadly, it's one of those things that's hard to replicate at a dealer. But at the same time, some of these little nuisances just piss me off.

Rant over, carry on. More or less just curious how many other people run into this same issue.

Edit (3/8/22): I'm going to write this off as an Android Auto glitch. The few times that I do have an issue with the screen (non-responsive, garbled mess, whatever), all I've done is disconnected Wi-Fi (which disconnects Android Auto), and reconnected to have everything working again.
 
Last edited:

Deano Bronc

Rank VI
Moderator

Don't delete

May 20, 2020
3,964
8,583
3,501
Winona Lake, IN, USA
First Name
Dean
Last Name
Smeltzer
Member #

0215

So it happens maybe once every 3 weeks, and it's basically nothing more than annoying when it does. It's as simple as turn truck off, open door (to finish process of turning off), restart Bronco, everything works again.

Sadly, it's one of those things that's hard to replicate at a dealer. But at the same time, some of these little nuisances just piss me off.

Rant over, carry on. More or less just curious how many other people run into this same issue.
I thought @SlashRacer was having a few issues with his screen but not sure if the problem just went away or he got it fixed.
 
  • Like
Reactions: EvlNvrDys

Bronco 202?

Rank VI

Don't delete

Sep 22, 2021
473
611
2,964
Arizona
First Name
Bob
Last Name
Vogel
Member #

104442

Take
So it happens maybe once every 3 weeks, and it's basically nothing more than annoying when it does. It's as simple as turn truck off, open door (to finish process of turning off), restart Bronco, everything works again.

Sadly, it's one of those things that's hard to replicate at a dealer. But at the same time, some of these little nuisances just piss me off.

Rant over, carry on. More or less just curious how many other people run into this same issue.
a video of it and show the dealership the outcome:)
 

EvlNvrDys

Rank VI

Champion I

Sep 1, 2021
509
901
2,964
Milford, NJ 08848
First Name
Greg
Last Name
Bradley
Member #

105178

Take

a video of it and show the dealership the outcome:)
Yeah I could do that. Took videos of my water in door, and my screen glitching out. And to be honest, I'm tired of the times I do take the Bronco to the dealer and they need to keep it for the day. But I will probably do the video thing next time it happens.
 
  • Like
Reactions: Bronco 202?

SlashRacer

Rank VI
Moderator

Don't delete

May 31, 2020
3,453
8,698
3,501
Allegan, MI, USA
First Name
Michael
Last Name
Heckman
Member #

0885

So it happens maybe once every 3 weeks, and it's basically nothing more than annoying when it does. It's as simple as turn truck off, open door (to finish process of turning off), restart Bronco, everything works again.

Sadly, it's one of those things that's hard to replicate at a dealer. But at the same time, some of these little nuisances just piss me off.

Rant over, carry on. More or less just curious how many other people run into this same issue.
I have the 12" screen.
I had something similar to this a month ago. Screen would work when I touched it, but it had double print for some of the buttons and the radio screen overlaid every screen I looked at. The problem went away after I shut it down and restarted it. That problem hasn't been back.
 

EvlNvrDys

Rank VI

Champion I

Sep 1, 2021
509
901
2,964
Milford, NJ 08848
First Name
Greg
Last Name
Bradley
Member #

105178

Yep, no double image on mine. It just goes dead. No matter where I touch it, nothing. I can change the radio using the steering wheel controls, but the touchscreen is useless until I restart the Bronco.
 
  • Like
Reactions: SlashRacer

SlashRacer

Rank VI
Moderator

Don't delete

May 31, 2020
3,453
8,698
3,501
Allegan, MI, USA
First Name
Michael
Last Name
Heckman
Member #

0885

I had a different issue with the screen on Tuesday. I went to the store in the evening, got out, closed the doors and locked it and walked away. When I came bake out 5 minutes later, my lights were still on and the screen was still lit up. I have had the screen stay on a couple of times. Each time it as stayed on, I would start it back up, turn it off and it would shut off correctly.
 
  • Like
Reactions: EvlNvrDys

Rjcook

Rank IV

Supporter I

Jan 28, 2022
107
177
1,192
Alabama Crimson Tide, Tuscaloosa, AL, USA
First Name
Robert
Last Name
Cook
Member #

5569

So it happens maybe once every 3 weeks, and it's basically nothing more than annoying when it does. It's as simple as turn truck off, open door (to finish process of turning off), restart Bronco, everything works again.

Sadly, it's one of those things that's hard to replicate at a dealer. But at the same time, some of these little nuisances just piss me off.

Rant over, carry on. More or less just curious how many other people run into this same issue.
Hi I have a Badlands non SAS and this happens to me also. Same thing I do to fix. It seems to be more of a problem when running android auto.
 
  • Like
Reactions: EvlNvrDys

VT Bronco

Rank II

Super Supporter II

Feb 14, 2022
45
60
281
Vermont, USA
First Name
Ryan
Last Name
Deppert
Member #

1

My 2019 Super Duty has done the same in the past. After some automatic updates is seems to have stopped. I think Android auto might have had something to do with it also.
 

EvlNvrDys

Rank VI

Champion I

Sep 1, 2021
509
901
2,964
Milford, NJ 08848
First Name
Greg
Last Name
Bradley
Member #

105178

Hi I have a Badlands non SAS and this happens to me also. Same thing I do to fix. It seems to be more of a problem when running android auto.
Mine did it again this morning. This time I took a video of me touching the screen in various places and nothing. Next time it happens I'll have to disconnect the phone and see if it is Android Auto causing it.

I guess all I can say about that is, at least I don't have the connectivity issues those people using Apple Car Play have. My phone never disconnects.
 
  • Like
Reactions: Rjcook

VT Bronco

Rank II

Super Supporter II

Feb 14, 2022
45
60
281
Vermont, USA
First Name
Ryan
Last Name
Deppert
Member #

1

Try going through the settings on the display and see if it needs or has the newest updates. I live where there is no cell service and have had trouble with it not being able to update. Again this is assuming that the unit is similar to my Super Duty.
 

EvlNvrDys

Rank VI

Champion I

Sep 1, 2021
509
901
2,964
Milford, NJ 08848
First Name
Greg
Last Name
Bradley
Member #

105178

Luckily I have pretty good cell service where I live... and most of the time where my Bronco travels. I'll check the settings later today just to be safe.

And it's actually odd it happened again today. Like my original post, it's usually like once every couple of weeks. So not a major issue, just a minor nuisance. My fear is I drive 25k+ miles/year. So if I don't get these little bugs worked out in the first year and a half, the Bronco will be out of warranty. :mad:
 
  • Like
Reactions: Deano Bronc

Mal

Rank VI

Champion I

May 21, 2020
708
1,671
3,501
Albuquerque NM
Member #

0283

Ive had this happen before on our Sedan (sync 1) and our Crossover (sync 3). Just like everyone, its a simple turn off the car, open the door and it reboots. We are using Mac equipment, so it may not be linked to just the Android handsets. Sync for the most part is pretty stable and works well, it just sure is irritating. maybe an OTA update can fix this.

Maybe its cosmic rays like the one that messed up the toyotas? :)

Toyota Recall Might Be Caused by Cosmic Rays | Live Science
 
  • Like
Reactions: EvlNvrDys

BShaffer

Rank III

Advocate I

Oct 9, 2021
2
3
808
Lincoln, CA
First Name
Brett
Last Name
Shaffer
Member #

103876

Went out to my OBX this morning and the screen is completely dead, nothing, zip, nada. I took a video and sent it to the dealership and they said to disconnect the battery for a second then reconnect. I will let you know how it goes.
 

Rjcook

Rank IV

Supporter I

Jan 28, 2022
107
177
1,192
Alabama Crimson Tide, Tuscaloosa, AL, USA
First Name
Robert
Last Name
Cook
Member #

5569

Yeah, touchscreen is dead, no sound, bluetooth, nothing. Tried disconnecting the battery then reconnecting, didn't work. Taking it in to the dealership on Monday.
Good luck, tell us what went wrong. I love my bronco my major concern is that is tech heavy. Having been in maintenance for many years the one thing I know is how guickly things become obsolete and parts no longer available
 

EvlNvrDys

Rank VI

Champion I

Sep 1, 2021
509
901
2,964
Milford, NJ 08848
First Name
Greg
Last Name
Bradley
Member #

105178

I think those who mentioned Android Auto may be on to something.
This was my screen while driving home today (happened half way into my hour drive)

20220222_165709.jpg

And it was unresponsive. Disconnected phone (while driving), screen went back to normal. Reconnected phone and all good.
 

Vinny

Rank III

Advocate I

Dec 1, 2021
1
1
808
Brick, NJ
First Name
Vincent
Last Name
LoPiccolo
Member #

4713

Had same issue with dead screen
took to dealer they ordered parts took month for parts to come in
They replaced CPU
now working again normal
 
  • Like
Reactions: EvlNvrDys