Soft top issues

BRNCOOZ

Rank IV

Super Supporter II

Jun 14, 2022
40
51
1,059
Orange County, CA, USA
First Name
Shaunt
Last Name
Oozoonian
Member #

110415

I tried rolling up my passenger window and it keeps rolling back down automatically as if something is in the way. It's not doing it anymore, but anyone how to fix? or what the problem could have been?
 

BRNCOOZ

Rank IV

Super Supporter II

Jun 14, 2022
40
51
1,059
Orange County, CA, USA
First Name
Shaunt
Last Name
Oozoonian
Member #

110415

Just wondering @BRNCOOZ , is your post related to the soft top, or a separate issue?
It could be. I'm wondering if the soft top being placed down incorrectly, or other issue with soft top construction, could stop the window from rolling up all the way. Are you trying to call me out for placing the question in this thread? haha
 

AcesandEights

Rank V

Champion I

Oct 22, 2020
2,268
4,087
2,723
Oregon, USA
First Name
Aresenio
Last Name
Beckman
No, I was trying to make sure I understood your question. It seemed to be a different issue, and I was trying to find the link between the soft top, the chip in the paint, the PPF and the window not rolling up. Just trying to make sure I understood your question.
 
  • Like
Reactions: BRNCOOZ

Bonnie6G

Rank VI

Champion II

Jan 19, 2021
437
893
3,501
Denver
First Name
Kyle
Last Name
Lesniak
Member #

2133

I have the same or a similar issue. I chalked mine up to my soft top not locking down when I put it back, but not sure. When I finally get a ppf wrap done, I plan to have them fix the chip before applying the wrap.
 

BRNCOOZ

Rank IV

Super Supporter II

Jun 14, 2022
40
51
1,059
Orange County, CA, USA
First Name
Shaunt
Last Name
Oozoonian
Member #

110415

On a hot day, some of the adhesive came gooey, when I folded the front open some adhesive dripped and drizzled onto my passenger window :(
 

thgdfathr

Rank VI

Champion III

Feb 26, 2022
821
2,106
2,964
Northern, VA, USA
First Name
Dan
Last Name
Sekely
Member #

5648

Only issue I have had so far was a weird squeak from top. Found out it was coming from here:
81AA84F7-18E0-4283-AAE4-807D02A7A444.jpeg
D3B51D9C-9DE6-4BE8-9536-6C7C08341F41.jpeg

Where the metal meets that plastic part that it rests on. Squeak only happened in opened half way. Looked like some of the paint was wearing off the metal on that first photo, so I put a small bit of general automotive grease in the groove to see if that will help.